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1. PENGENALAN EVIEWS 

Eview merupakan alat statistik dan ekonometrik yang membantu pengguna software ini 

untuk membuat pemodelan dengan tiga cara, yaitu mengunakan main menu bar, command 

windows, object windows atau work area. Eviews memberikan kemudahan untuk 

memberikan informasi bagi pengguna untuk dapat melakukan analisis statistik, memberikan 

forecasting, model simulasi, serta memberikan kemudahan untuk membuat tabel dan grafik 

yang sering digunakan dalam publikasi karya ilmiah dan publikasi hasil estimasi para ekonom. 

1.1. Workfile: Dokumen Dasar Eviews 

Pada gambar 1 terlihat gambar tampilan awal dari eviews. Tahapan pertama dalam 

mengerjakan data di eviews adalah membuat workfile atau kertas kerja eviews. Caranya 

adalah pilih file > new > workfile  

 

  

 

Gambar 1. Tampilan Eviews awal 

 

Pada saat membuat workfile yang baru, disana terdiri dari workfile structure type, data 

specification, dan workfile name. Bila sudah terbuka maka ada tiga hal yang perlu 

diperhatikan, yaitu sediakan data yang akan kita masukkan ke eviews (data EXCEL atau SPSS), 

kemudian cek data typenya (character, number, date), lalu basic structurenya dan frekuensi 

spesifikasi data (annual, semi annual, quarterly, monthly, weekly, intraday). Kita juga dapat 

memilih mulai data mana yang akan diobservasi.  Workfile akan memperlihatkan data sudah 

masuk bila obeservasi kita sesuai dan masing-masing varaibale terlihat memiliki grafik kecil-

kecil.   
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Gambar 2. Workfile dan Contoh Open Workfile 

Singkatnya:  

1. File > New >Workfile 

2. Pilih Dates-Regular Frequency 

3. Pilih Monthly dari menu Date Specification 

4. Tuliskan start data .... dan end data .... 

  

Gambar 3. Membuat Workfile 

 

Kita juga dapat melakukannya dengan cara menulis perintah di command window. Tulislah 

sebagai berikut: 

wfcreate (wf=monthly, page=dated) m 2014 2016 

 

Path/directory 
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Perintah di atas untuk data time series, sedangkan perintah untuk data panel yang berisikan 

12 data kuartalan sebagai berikut: 

wfcreate (wf=panel, page=country) q 2014 2016 12 

  

Gambar 4. Membuat Workfile dengan Comand 

Cara berikutnya yaitu melakukan import data dari excel ke eviews. Langkah-langkahnya 

adalah sebagai berikut ini: 

1. File > Open > Foreign Data as Workfile 

2. Pilih data yang mau dibuka baik bentuk excel ataupun spss 

3. Bila sudah terbaca oleh eviews akan ada dialog muncul untuk memastikan data yang 

dipilih sesuai dengan yang kita inginkan. Seperti data typenya (character, number, 

date), lalu basic structurenya dan frekuensi spesifikasi data (annual, semi annual, 

quarterly, monthly, weekly, intraday). 

4. Finish 

  
  

Gambar 5. Import Data Excel ke Eviews 
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Setelah dilakukan seperti tampilan di gambar 5, maka akan muncul tampilan seperti gambar 

6, sehingga perlu dilakukan pemilihan tipe datanya, stuktur dasarnya, serta spesifik frekuensi 

datanya. Hal ini biasanya dikatakan sebagai dialog data di eviews. 

  

Gambar 6.Dialog Data di Eviews 

Import data juga dapat dilakukan dengan copy paste sebagai tambahan metode membuat 

workfile. Langkah-langkahnya sebagai berikut: 

1. Copy sumber data (EXCEL atau SPSS) 

2. Klik kanan ketika sudah berada di work area 

3. Paste as New Workfile 

4. Terbuka open dialog sama dengan sebelum-sebelumnya. Seperti data typenya 

(character, number, date), lalu basic structurenya dan frekuensi spesifikasi data 

(annual, semi annual, quarterly, monthly, weekly, intraday). 

5. Finish 

 

 

 

Gambar 7. Copypaste Data dan Dialog Data 
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Langkah-langkah membuat workfile telah selesai, anda dapat menyimpan pekerjaan anda 

dengan cara save as seperti biasa, hanya akan memilih 7 atau 16 digit character. Kemudian di 

Ok. 

 

 

Gambar 7. Save Pekerjaan EViews anda 

Bila ada workfile yang dibentuk dari tampa melakukan import data excel, maka akan ada save 

data  dengan memberikan nama pada data yang mau disimpan. Caranya, ada tombol  

yang dapat dipilih untuk menampilkan object nama. Maksimum nama objeknya 24 karakter, 

disarankan untuk kurang dari itu. 

 

 

Gambar 8. Save dengan memberikan nama 

Pada gambar 9 terlihat gambar-gambar kecil (ikon-ikon) yang menunjukkan fungsi dari data yang ada 

di eviews. Pada dasarnya yang sering terlihat adalah dan  . merupakan data time series dan 

 merupakan koefisien. Ikon-ikon selengkapnya ada di gambar 9. 
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Gambar 9. Ikon-Ikon Tipe Objek 

Sumber: www.eviews.com. 
 

1.2. Sample 

Eviews memberikan fasilitas, semua data dapat masuk dalam eviews sebagai range, 

oleh karena dapat dilakukan sample dalam range tersebut. Misalnya contoh time 

series di atas sebelumnya, memperlihatkan ada 3 tahun observasi. Bila kita 

menggunakan semuanya dapat kita ketik @all atau @first @last seperti pada gambar 

di bawah ini.  

 

Gambar 9. Fungsi-fungsi untuk sample 

Pada gambar 10 merupakan contoh dari menggunakan fungsi-fungsi tersebut. Terlihat 

pada bagian kiri semua observasi menjadi sample, namun sebelah kanan hanya satu 

samplenya dari range data yang ada. 

  

Gambar 10. Contoh Fungsi dan Sample 
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2. Series dan Group 

Data series dan group merupakan data yang penting dalam menggunakan eviews untuk 

menganalisa. Nilai numerik aktual akan memiliki tanda series  dan data group object 

berseries memiliki tanda . Sama seperti sebelumnya akan diberikan contoh membuat 

series langsung dari eviews, mengimport data dari data series yang sudah ada file excel, 

dan membuat group dan bekerja dengan group data series. Anda dapat menyobanya 

semua dengan tahapan yang sama dengan tahapan latihan di atas pada awal kali kita 

mengenal eviews. Saat ini kita akan membuat dari data series dari equation (persamaan). 

Adapun langkah-langkahnya sebagai berikut: 

1. Klik halam time series 

2. Quick > Generate > Series dari menu toolbar 

3. Tulis persamaan: w1=log (jkse) 

4. Muncul data series yang baru dengan nama w1 dan ikon  

  

Gambar 12. Data Series dari Persamaan 

Berikutnya kita coba untuk membuat kelompok dari data series yang sudah ada. Adapun 

data yang digunakan adalah Data series yang diambil adalah data indeks asean dan tingkat 

suku bunga. Data Series 1: TS INDEKS PASAR MODAL ASEAN dan Data Series 2: TS SUKU 

BUNGA NEGARA ASEAN. 

  

Gambar 13. Data Series yang digunakan 
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Sekarang kita gunakan data-data tersebut ke dalam eviews. Maka langkah-langkahnya 

sebagai berikut: 

1. File > Open > Foreign Data as Workfile 

2. Pilih data yang mau dibuka baik bentuk excel ataupun spss 

3. Bila sudah terbaca oleh eviews akan ada dialog muncul untuk memastikan data yang 

dipilih sesuai dengan yang kita inginkan. Seperti data typenya (character, number, 

date), lalu basic structurenya dan frekuensi spesifikasi data (annual, semi annual, 

quarterly, monthly, weekly, intraday). 

4. Pilih Quick di bar menu  

5. Pilih Empty Group (edit series) 

6. Pilihlah data series dari workfile pertama (GJKSE, GKLSE, GSTI, GPSE, GSETI) 

7. Pilihlah label name untuk menamai group 

8. Kemudian save 

  

Gambar 14. Group Data Series dan Penamaan Group 

Setelah kita sudah dapat membuat workfile, data series dan data group, kita akan 

mengenal lebih dahulu membuat grafik dasar sebelum masuk ke persamaan regresi 

sederhana dan regresi berganda. 

 

3. Grafik Dasar 

Tipe grafik ada 4 kelompok, dengan kategori sebagai berikut: 

1. Grafik observasi -> grafik memperlihatkan data setiap observasi dalam kelompok 

series ataupun group. 

2. Grafik analitikal -> grafik memperlihatkan hasil analisis data series atau kelompok. 

3. Grafik Auxilary -> grafik memperlihatkan hasil analisis dari modifikasi grafik observasi. 
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4. Grafik Kategorikal-> grafik memperlihatkan grafik observasi atau analisis yang dibagi 

atas kategorikal berdasarkan variabel-variabel faktor yang dilakukan. 

Mari kita membuat grafik sederhana dengan langkah-langkah sebagai berikut ini: 

1. Buka workfile series atau group yang sudah kita lakukan 

2. Klik view > graph 

3. Kotak dialog > basic graph dn spesifik line & symbol 

4. Grafik sederhana terbentuk, dapat di geser-geser time framenya 

   

Gambar 14. Grafik dari Data Series 

Grafik sederhana tersebut dapat kita lihat pergerakannya dengan cara menggeser ke 

kanan atau ke kiri untuk melihat kondisi datau pergerakan data observasinya. 

 

4. Regresi Sederhana 

Analisis data yang paling dasar namun paling penting bila menggunakan data dengan 

series dan group series adalah melakukan uji statistik dengan regresi sederhana maupun 

regresi berganda. Eviews memberikan statistik deskripsi, grafik statistik, uji-uji dan 

prosedur-prosedur. Sebagian besar menggunakan menu item  VIEW dan PROC. Mari kita 

lakukan pengujian statistik secara umum untuk regresi sederhana, dengan langkah-

langkah sebagai berikut: 

1. Open workfile dengan data time series 

2. Pilih JKSE 

3. Klik view (kelompok pertama untuk views dan display berisikan spreadsheet dan 

graph; kelompok kedua statistik pada umumnya berisikan descriptive statistics & test; 

kelompok ketiga statistik umum untuk times series berisikan one-way tabulation, 

correlogram, long-run variance, unit root test, variance rasio test, bds independence 
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test; kelompok keempat menjadi tempat modifikasi display dengan label series yang 

sesuai dengan keinginan ) 

4. View > Descriptive Statistics & Test > Histogram & Stats 

  

Gambar 15. Hasil Uji Data Series Statistik Deskriptif 

Gambar 15 memperlihatkan grafik JKSE yang skweness ke kanan serta Jarque-Bera 

Statistic  menjukkan angka p-value 0.451711, artinya data ini belum normal.  

Jika kita inginmengetahui seluruh data, serta mau melihat tabulasi data count dan 

kumulatif count, maka kita lakukan one-way tabulation. Langkah-langkahnya adalah: 

1. Buka worfile kita gunakan command (smpl @all) 

2. Klik cross_section 

3. Klik View > One-Way Tabulation, jangan lupa uncheck centang di under the section 

“group into bins if” 

 

 

 

Gambar 16. Hasil Uji Data dengan One Way Tabulasi 
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Kita juga dapat melakukan Statistik Deskriptif dengan cara tabel statistik, dengan langkah-

langkah sebagai berikut: 

1. Open workfile pilih data yang akan dilihat Statistik Deskriptifnya 

2. Kilik View > Descriptive Statistics & Test  > Stats Table 

3. Kelebihannya dengan cara table ini dapat lebih mudah melakukan copi hasilnya ke 

word atau ke program spreadsheet (Excel). 

  

Gambar 17. Hasil Uji Data dengan Tabel Statistik Deskriptif 

Kita juga dapat melakukan Statistik Deskriptif dengan klasifikasi atau kategori, dengan 

langkah-langkah sebagai berikut: 

1. Open workfile pilih data yang ingin dilihat statistik deskriptifnya 

2. Klik View > Descriptive Statistics & Test > Statistic by Classification 

3. Dialog Box Open , pilih statisk yang ingin di lihat pada item ststistics  

4. Pilih JKSE  pada series atau group untuk klasifikasi.  

  

Gambar 18. Hasil Klasifikasi Group Statistik Deskriptif 
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Eview memberikan kita fasilitas akan uji hipotesis di main menu Descriptive Statistics & 

Test. Pada uji ini perlu mengerti akan teori serta variabel-variabel apa yang diujikan. Uji-

uji itu terdiri dari: 

1. Uji sederhana artinya menguji rata-rata, median, dan variance dari data series. 

2. Uji equily dengan klasifikasi artinya menguji rata-rata median dan variances across 

subsamples (subgroups) dalam series yang sama. 

3. Uji distribusi empris artinya uji data distribusi series tergambar pada nagka-angka 

dengan distribusi yang sudah diketahui. 

Uji Sederhana dengan langkah-langkahnya sebagai berikut: 

1. Buka workfile pilih JKSE 

2. Klik View > Decriptive Statistics & Test > Simple Hypothesis Tests 

3. Series Distribution Dialog terbuka, pilih mean dengan nilai uji 5000 

4. Klik Ok 

  

Gambar 19. Hasil Uji Sederhana 

Hasil pada gambar 19 memberikan pengertian akan Indeks Saham Gabungan (IHSG) yang 

diberikan namanya JKSE (Jakarta Stock exchange) memilki p-value sebesar 0.44 

memberikan rata-rata indeks dengan angka 4957.52 dan standar deviasi sebesar 330.71. 

Artinya uji sederhana akan rata-rata keseluruhan JKSE selama 3 periode dapat mencapai 

batas IHSG di angka 5000. 

Uji klasifikasi dengan langkah-langkahnya sebagai berikut: 

1. Buka workfile pilih JKSE 

2. Klik View > Decriptive Statistics & Test > Equality of classification 
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3. Series Distribution Dialog terbuka, maka isilah yang ingin dilihat kualifikasi yang sama.  

4. Klik Ok 

Uji hipotesis dengan menguji distribusi empiris. Uji ini memberikan kesempatan untuk 

menguji distribusi parametrik yang sesuai dengan mana yang akan dites distribusi 

empirisnya (test specification). Ada juga pengendalian dengan cara estimasi namun sering 

proses estimasi ini gagal dalam prosesnya (estimation options). Langkah-langkahnya 

sebagai berikut: 

1. Open Workfile, pilih data series 

2. Klik View > Descriptive Statistics & Tests > Empirical Distribution Tests 

3. Terbuka dialog memilih Test Specification atau Estimation Options 

4. Parameters dikosongkan saja 

5. Klik Ok 

  

 Gambar 20. Hasil Uji Sederhana 

Dependen serial (dependen temporal) adalah fiture time series data. Views untuk data 

series akan diperlihatkan autocorrelation dan partial correlation (tergantung angka 

spesifik lag yang diberikan). Adapun langka-langkanya sebagai berikut: 

1. Klik Timeseries di workfile. Buka data series SBI dan GJKSE. 

2. Klik View > Correlogram 

3. Terbuka dialog kotak yang meminta kita untuk memilih 

a. Levels (x) 

b. First difference (x-x(-1)) 
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c.  Second difference ((x-x(-1))-(x(-1)-x(-2)) 

4. Tipe lags yang default 36 tidak perlu di otak-atik 

5. Klik Ok 

  

Gambar 21. Autokolerasi dengan 1 lag (level) 

Autokorrelasi (AK) merupakan koefisien kolerasi untuk nilai data series k-periode. Jika 

autokoerelasi ini hilang secara geometrik sebanyak k yang bertambah, maka ini 

menandakan low-order Autogressive (AR). Jika nilai AK pertama bukan nol, itu artinya 

data series dengan first-order terkorelasi secara serial. Jila sebaliknya drops ke nilai nol 

setelah angka kecil angka lags, ini menandakan low-order Moving Average (MA). 
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